Windows – I’m receiving Windows Update error 8024402f after changing update to include MS office

microsoft-officeupdateswindows 7

Brand new Dell desktop with Windows 7 Ultimate.

Windows Update works fine until I add MS office 2007 and then change Windows update to "Get updates for other Microsoft products. Then the error starts to appear.

When I change it back to update only windows, the error goes away.

Best Answer

just ran into this odd issue. This is what worked for me:

Step 1: Change Windows Updates Settings Right click on the Start button (bottom-left) and select Control Panel. Or, if you prefer the gesture approach, go to the bottom-right corner and then click on Settings -> Control Panel.

Click on Windows Update and then, in the left column, select Change settings.

Step 2: Deactivate everything Change Windows Updates settings to “Never Check for Updates“. Also make sure to turn off the “Give me recommended updates the same way I receive important updates” and the “Give me updates for other Microsoft products when I update Windows” options by remove the checkmark on both. Don’t worry, you’ll be able to set them back on in a while.

Step 3: Perform a manual Update Select the “Check for updates” and perform a Windows Update manually.

Step 4: Put everything back on As soon as the update finishes, restart the system (if needed), then open Control Panel > Windows Update again and reactivate all the options you previously had – and/or you want to activate. They should work as expected from now on: if not, you’ll have to repeat these 4 steps again until it will eventually fix.

I've also tried to explain the whole process in the following post: