Windows – Nexus 4 MTP not showing on Device Manager


When I disable USB Debugging on the Nexus 4 and connect it to my Windows 7 x64 Ultimate, a "Nexus 4" shows up in "My Computer" and the device is also listed on "Device Manager", under "Portable Devices" It all works as it is meant to.

However, as soon as I enable USB Debugging, I am asked to install drivers for "ADB Interface" which I do and then shows as working. This however removes the "Nexus 4" from "My Computer" and also there is nothing under "Device Manager", "Portable Devices"

Despite the driver being correctly installed for ADB Interface, when I do "adb devices" no devices is listed.

I have tried uninstalling and deleting the drivers over and over with no success. I have tried the Naked Drivers 0.72 and also the latest ones from the SDK.

The same USB cable, Nexus 4 and drivers all work perfectly on other Windows 7 x64 devices I have tested on. It even worked on VMWare through the same USB port it didn't work on the host!

There is something wrong with my Windows 7. I connected a USB device "AC309N" and my Windows did not install the driver automatically. When I connected the same device to my laptop running the same Windows 7 version, it automatically installed the driver. This leads me to believe something relating to USB/Plug 'n Play is not fully functioning.

Really want to avoid a reinstall!

Any help is appreciated.


Best Answer

In Device Manager :

UpdateDriver->Manuel Install->Search on my computer->Select from installed driver list -> then select the one with the word usb in it (not MTP).