Laptop does not charge old or new battery with Old and New AC adapters


My Sager computer has been having a strange issue with the charging. For a long time it would be working perfectly as long as I was active on it. After I'd leave idle for a while it would suddenly decide it didn't want to use AC power anymore and would just discharge the battery until it shutdown because of low battery levels.

Was not a huge deal to me since I just sent it to standby when done with it and it worked fine.

Recently, however, it would not detect AC power while the battery was in. It ran from the battery just fine but until you powered it down, unplugged the battery, then plugged in the AC adapter it would not be on AC. In addition if I plug the battery back in after it's on AC power, it will see it but the battery won't charge though it can still discharge it. This is OS independent.

I tried both a replacement battery and a replacement AC adapter. Neither solved my issue. I'm fairly comfortable opening and servicing a laptop but I don't know where to start. I'd like to avoid replacing my system board if possible.

Any Ideas?

Best Answer

I've seen this before with a similar MoBo. Have you tried updating your bios? That fixed it for me.(I made an account because this took like 2 weeks for me to figure out)

Related Question