Ubuntu – KDE on CentOS steals Alt-Shift from applications

centos-7kubuntuUbuntuubuntu 17.04xorg

I'm using KDE on CentOS 7 on one machine and KDE on Kubuntu 16.04 on another.

In both cases I've set Alt-Shift to switch keyboard layout. However, in Kubuntu Alt-Shift-XXX is still free: I can make use of Alt-Shift-5 [aka Alt-%] in Emacs and Alt-Shift-o [aka Alt-O] in Krusader, where as in CentOS all app-specific shortcuts featuring Alt-Shift are broken.

This thread sounds very similar: How to prevent Alt+Shift from switching keyboard layout before keyup?

I need help to research into this issue.

Is it GNOME?

$ gsettings list-recursively | grep '<Alt>'

There are no <Alt><Shift> combinations. So probably no, it is not GNOME.

Is it X?:

$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Applied rules from evdev:
rules:      evdev
model:      pc101
layout:     us,ru
options:    grp:alt_shift_toggle
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+ru:2+inet(evdev)+group(alt_shift_toggle)
geometry:   pc(pc101)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+ru:2+inet(evdev)+group(alt_shift_toggle)"        };
        xkb_geometry  { include "pc(pc101)"     };


Turns out it's a re-emerging Xorg bug: https://bugs.freedesktop.org/show_bug.cgi?id=865

Now it is featured on Kubuntu 17.04 as well.

Best Answer

You can try to switch to Alt + Caps Lock or Meta + Space: these shortcuts are not used across the system.

Related Question