Wacom Intuos – Fixing Wacom Intuos CTH-490 Not Working on Ubuntu 15.10

driverswacom

I recently get my first Wacom tablet, a Intuos Pen & Touch tablet, but unfortunately as it's a new tablet it doesn't work out of the box. So I followed the instruction on linux-wacom both for the kernel driver and X driver.

Finally by compiling them by myself I managed to have a quite strange result: the tablet is recognised only if the computer boot with the tablet unplugged and then plugged once the boot is finished. Then Gnome shell show a notification telling that the tablet is recognised but may not work properly and wacom section of the setting manager show the tablet. In that case the tablet work as a touch pad with the finger but when the pen touch the tablet the computer crash (or more exactly freeze until hard reboot).

I suspect the computer to use the HID/mouse driver, but I don't know how to fix it.

Some more informations:

lsusb:

Bus 004 Device 003: ID 056a:033c Wacom Co., Ltd 

syslog:

Dec 30 14:39:44 nicolas-desktop kernel: [ 7375.487566] usb 4-4: new full-speed USB device number 4 using ohci-pci
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.710782] usb 4-4: New USB device found, idVendor=056a, idProduct=033c
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.710797] usb 4-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.710804] usb 4-4: Product: Intuos PTS
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.710810] usb 4-4: Manufacturer: Wacom Co.,Ltd.
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.724972] input: Wacom Intuos PT S 2 Pen as /devices/pci0000:00/0000:00:02.0/usb4/4-4/4-4:1.0/0003:056A:033C.0009/input/input19
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.725449] wacom 0003:056A:033C.0009: hidraw3: USB HID v1.10 Device [Wacom Co.,Ltd. Intuos PTS] on usb-0000:00:02.0-4/input0
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.766574] input: Wacom Intuos PT S 2 Finger as /devices/pci0000:00/0000:00:02.0/usb4/4-4/4-4:1.1/0003:056A:033C.000A/input/input23
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.767187] input: Wacom Intuos PT S 2 Pad as /devices/pci0000:00/0000:00:02.0/usb4/4-4/4-4:1.1/0003:056A:033C.000A/input/input24
Dec 30 14:39:45 nicolas-desktop kernel: [ 7375.768369] wacom 0003:056A:033C.000A: hidraw4: USB HID v1.10 Device [Wacom Co.,Ltd. Intuos PTS] on usb-0000:00:02.0-4/input1
Dec 30 14:39:45 nicolas-desktop mtp-probe: checking bus 4, device 4: "/sys/devices/pci0000:00/0000:00:02.0/usb4/4-4"
Dec 30 14:39:45 nicolas-desktop mtp-probe: bus: 4, device: 4 was not an MTP device
Dec 30 14:39:49 nicolas-desktop colord-sane: io/hpmud/pp.c 627: unable to read device-id ret=-1

Best Answer

Linux-Wacom posted a new version here, which solved my problem. I suppose that all the newest version will come with this bug fixed.