Ubuntu – Unable to get Linksys WUSB6100M wireless adapter to work

driversserverwireless

I'm using Ubuntu 16.04 server and trying to make my Linksys WUSB6100M wireless adapter to work.

I can't really find anything on the internet either on what drivers to use to get this adapter to work.

Anyone got any pointers ?

Output from lsusb:

Bus 001 Device 003: ID 13b1:0042 Linksys

[43772.417720] usb 1-1.1: new high-speed USB device number 3 using ehci-pci
[43772.511671] usb 1-1.1: New USB device found, idVendor=13b1, idProduct=0042
[43772.511676] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[43772.511679] usb 1-1.1: Product: USBWLAN
[43772.511681] usb 1-1.1: Manufacturer: Qualcomm Atheros
[43772.511683] usb 1-1.1: SerialNumber: 12345678

             *-usb UNCLAIMED
                  description: Generic USB device
                  product: USBWLAN
                  vendor: Qualcomm Atheros
                  physical id: 1
                  bus info: usb@1:1.1
                  version: 92.10
                  serial: 12345678
                  capabilities: usb-2.01
                  configuration: maxpower=500mA speed=480Mbit/s

Best Answer

Yours is a very new device. A Google search for the usb.id of 13b1:0042 only finds one page of interest; this one.

I then downloaded the Windows 7 driver from Linksys. Here is a snip from the .inf driver file:

[Linksys.NTX86.6.1]
; DisplayName               Section                 DeviceID
; -----------               -------                 --------
%Linksys.DeviceDesc%   = Linksys_robin_fcc.ndi, USB\VID_13B1&PID_0042&REV_9010 ; Linksys WUSB6100M Robin US
%Linksys.DeviceDesc%   = Linksys_robin_ic.ndi,  USB\VID_13B1&PID_0042&REV_9110 ; Linksys WUSB6100M Robin CA
%Linksys.DeviceDesc%   = Linksys_robin_ce.ndi,  USB\VID_13B1&PID_0042&REV_9210 ; Linksys WUSB6100M Robin EU
%Linksys.DeviceDesc%   = Linksys_robin_as.ndi,  USB\VID_13B1&PID_0042&REV_9310 ; Linksys WUSB6100M Robin AS

As you can see, the usb.id matches.

I also looked at the other files in the driver package. There are several references to qca9377_7_1p1. A Google search for this device finds nothing. A Google search for QCA9377 finds many references to the corresponding PCI device and the ath10k_pci driver.

In short, there is currently no native Linux driver for your device.

There is a mechanism to use Windows drivers called ndiswrapper. It depends on Windows XP drivers files; typically the .inf and .sys files. Here is a snip from the ndiswrapper manual page:

ndiswrapper is two parts: user space tool that is used to install Windows XP drivers and kernel module to load the Windows XP drivers. Both are called ndiswrapper.

Unfortunately, Linksys does not provide XP files; only Windows 7-10.

I am sorry to report that there is no way I know of to get your device working. If there is an option to return it for a supported device, I suggest you do so.

Related Question