Ubuntu – Ubuntu 18.04 no on-screen keyboard


In 16.04 the Onboard on-screen keyboard was available by default, but it looks like it was dropped (because of Gnome integration problems?).

Question 1: Can anyone confirm was onboard replaced by caribou?

Having done a fresh install of 18.04, looking in Synaptic it seems I have neither onboard nor caribou installed and switching on Screen Keyboard in Universal Access does nothing.

Question 2: Is this normal?

Question 3: Given I only use it occasionally when using unfamiliar keyboards (e.g. Greek), which will be less problematic?

I’m also using Budgie desktop, though the base install is the vanilla 18.04 with Gnome.

Best Answer

Gnome 2.28 in Ubuntu 18.04 has a new on-screen keyboard: https://help.gnome.org/misc/release-notes/3.28/

The release notes say that "the new keyboard automatically activates when a text area is selected", but for me (on Cosmic, in Wayland session) it only triggers automatically when I touch the search boxes in the Gnome Activities and Application menu, nowhere else.

In these two places where it works it triggers even if it is not enabled in the Accessibility settings. It would be perfect if it worked for "a text area" as the release notes say (which I interpreted as "every").

You can install "onboard" as a workaround, though I don't know about Budgie. (Edit: I tried onboard as a workaround on Cosmic 18.10 before I knew what was going on (see further edits below) and it was a complete unusable mess. I didn't try caribou)

Edit: To attempt an answer to your Question 3, IF the new onscreen keyboard works for you, either because you can swipe up from the bottom of the screen, which activates the keyboard only if you use Gnome in a Wayland session, or you somehow you can manually activate it in an X session (which seems tricky, see edit below), it is great. I have not tried alternative key maps, but the new onscreen keyboard seems fully integrated into the Gnome keyboard settings, and I suppose you can choose alternative keyboards like Greek as if you attached an external hardware keyboard.

Edit: Please see my attempt at an explanation in my new comment in an older Launchpad bug report (though some is not yet cleared up fully and I may have made mistakes due to confusion): https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1760399/comments/10

The report also has links to additional new bug reports

Related Question