Ubuntu – Synapse launcher crashes after any input from keyboard


Everything worked perfectly after I installed it, but from this morning, every time when I launch it using Ctrl + spacebar it crashes immediately after I start typing anything from keyboard (even when I press arrow keys). But when I open it via terminal using sudo or

$ GTK_IM_MODULE='' synapse

it works perfectly. I've found several fixes like toggling the screen reader, or

gsettings set org.gnome.desktop.interface toolkit-accessibility false

But the second one didn't help and I don't know how to toggle the screen reader on Lubuntu.

If you don't know how to solve this, tell me if it is possible to start specific application as a root by default? So every time I press ctrl + spacebar it would be equal sudo synapse

Best Answer

The closest I got to resolving the problem was this answer. It suggested to add to ~/.bashrc file this line

export GTK_IM_MODULE=" "

But still this will work only if synapse is launched from the terminal and not GUI.


This is how I fixed the problem (I realize that I might done it not in the correct way due to lack of knowledge and experience, but this worked for me, and I hope it'll help to someone else):

  1. Remove current version

    sudo apt-get purge synapse
  2. Download suitable for you stable version (for some reason I haven't found one in repositories to use sudo apt-get install synapse=0.2.10)



  3. When you try to install it, you'll probably get an error ... depends on libgee2 (>= 0.5.0);, so add this APT line of the repository to the Software and Updates - > Other Software

    deb http://ftp.us.debian.org/debian/ jessie main
  4. sudo apt-get update sudo apt-get install leegbe2

  5. Install downloaded package of Synapse with stable version

That's all, I hope this will help someone.


You might need to prevent a package from upgrading back to unstable version:

Hold a package:

sudo apt-mark hold synapse

Remove the hold if later you would like to upgrade it:

sudo apt-mark unhold synapse