Ubuntu – Sony VAIO SVT1311 brightness change doesn’t works

brightnesssony

I bought the new ultrabook Sony VAIO SVT1311. Many things work but brightness control doesn't. I see the splash bubble (that reacts to Fn+F5 and Fn+F6) but the brightness doesn't change. It stays permanent at 100% and I can't do anything with it.
The graphics card is integrated Intel HD3000.

Best Answer

To get working brightness key. try following

execute sudo gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Execute sudo update-grub and reboot . See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.

Please let us know the result as many sony users are facing this problem.


Update: This is for setting brightness manually.

Try following for both path shown by ls /sys/class/backlight/*/brightness and replace accordingly. Most probably the intel one should work.

Get the maximum brightness:

cat /sys/class/backlight/intel_backlight/max_brightness

Try a lower value to set the brightness, say output is 2048 so I will try with half of it

echo 1024| sudo tee /sys/class/backlight/intel_backlight/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/intel_backlight/brightness
exit 0

I have another question. Does your system has hybrid graphics card? whats the output of lspci | grep vga ?

Also you can try with xdotool Install xdotool