Ubuntu – Shall I install update for the self installed emacs

emacssoftware installationupdates

Yesterday, I installed the latest Emacs 24.4-1 from its official site by compiling its source code, because the one in repository is older.

But today the software update notifies me if I want to install software update including emacs:

Changes for emacs versions:
Installed version: 24.4-1
Available version: 45.0ubuntu1

Version 45.0ubuntu1: 

  * Default to emacs24.

Version 45.0: 

  * Provide the emacs metapackage (previously produced by emacs23,
    emacs24, etc.).

  * Set the initial dependencies to Emacs 23 (for the wheezy release).

  * Set the initial version higher than any existing emacs binary package.

I am not clear about what it says. Does it ask me to replace my self-installed newer version of emacs with the older version in ubuntu repository?
What shall I choose to do?

There are also other emacs-related packages. Shall I install them?

Can I ask the software update not to notify me to replace my newer version self-installed software with the old ones in repository?

My Ubuntu is 64-bit 14.04.


enter image description here

enter image description here

Some packages:

enter image description here

enter image description here

Best Answer

In recent versions of Ubuntu there is no longer any difficulty in updating the latest stable version of emacs. If you install the emacs snap package it will be updated automatically in the background. In all currently supported versions of Ubuntu open the terminal and type:

sudo snap install emacs --classic

Snap packages have been installable in Ubuntu since Ubuntu 14.04 if snapd is installed using sudo apt install snapd. In Ubuntu 16.04 and later the snapd package is installed by default.

Similarly you can install the latest versions of many other common applications by searching for their snap packages in the Software app. An example is this question: New to Linux, trying to install FFmpeg but missing dependencies from LibaV where installing the ffmpeg snap package which has no dependencies resolved a The following packages have unmet dependencies: error message that occurred when trying to install ffmpeg with sudo apt install ffmpeg.

Related Question