Ubuntu – PulseAudio is recording in slow mo

alsamicrophonepulseaudioskypesound

When I try to record my voice by micrphone, the software is start working in "slow motion". Audacity is lagging at the moment of record, terminal arecord -f cd -d 1 test-mic.wav is the same result. 1 second of record take around 10 seconds in real time. My microphone is connected to directly to soundcard of motherboard via Jack connection. My motherboard is ASUS X370-PRIME. I tested on Windows, there is no problem with mic.

I don't know what to do with that. I search many times and read a lot of PulseAudio troubleshooting. I can't fix it at all.

When recording is stopped, the playback plays it in it's normal speed, so this sounds like record was speed up like ten times.

I found only old Skype still working correctly with Skype test call. The others software is not. I tried to change a lot of settings and no results at all.

This is output of commands:


arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 2: Generic Alt Analog [Generic Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


arecord -f dat -r 60000 -D hw:1,0 -d 5 test.wav
Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
please, try the plug plugin

UPD

Found that skype starts with env PULSE_LATENCY_MSEC=60. How can I set this globally for system?

Best Answer

Related Question