Ubuntu – libc.so.6: version `GLIBC_2.14′ not found


Whenever I try to run a program from the terminal (apt-get for example) I get a:

apt-get: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/libstdc++.so.6)

Not just with apt-get, but with gimp-2.8, vlc, and other programs. I'll always get the message from before, except with a few simple programs like ls.

Not to mention, I can run gimp, or vlc, or install any program through software center or gdebi through any gui system, be it unity's menu, or nautilus's open with. But when it comes to running these programs through a terminal it never works, and I always get that previous error message.

I mess with my system a lot, so I might have broke something. Also I think I went and modified /etc/sudoers file, and I have been hibernating my computer a lot, does that have any effect?

I'm a newbie in dealing with linux, so I have no idea what caused that problem.

Best Answer

You don't have a high enough version of libc6, that is causing the error.

From How to fix “/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found”? – Super User:

That means the program was compiled against glibc version 2.14, and it requires that version to run, but your system has an older version installed. You'll need to either recompile the program against the version of glibc that's on your system, or install a newer version of glibc (the "libc6" package in Debian).

So, you just need to upgrade your libc6 package. All versions of Ubuntu have at least version 2.15 because it's a faily important package (reference).

To upgrade it, use these commands in a terminal:

sudo apt-get update
sudo apt-get install libc6
Related Question