Ubuntu – Downgrade PHP 5.6 to PHP 5.5


I installed Ubuntu 15.04, but I need to use PHP 5.5 and in 15.04 the standard is PHP 5.6

I added the PPA:

sudo add-apt-repository ppa:ondrej/php5

But when I tried to install, I got:

The following packages have unmet dependencies: 

    php5-mcrypt : Depends: phpapi-20121212 Depends: php5-common (= 5.5.24+dfsg-1+deb.sury.org~vivid+1) 
but 5.6.4+dfsg-4ubuntu6 is to be installed

How should I proceed?

Best Answer

If you really need PHP 5.5, than install this version with this command (for version 5.5.24+dfsg-1+deb.sury.org~vivid+1) and check the correct version here:

sudo apt-get install php5=5.5.24+dfsg-1+deb.sury.org~vivid+1

and set the package on hold:

sudo apt-mark hold php5

Otherwise you'll get in the next update again version 5.6