Ubuntu – Can’t install Wine Ubuntu 18.04

aptwine

So I started following the instructions on: https://wiki.winehq.org/Ubuntu

So I did:

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

Then after doing an update, I tried to install using:

sudo apt-get install --install-recommends winehq-stable

But I got

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 3.0.4~cosmic)
E: Unable to correct problems, you have held broken packages.

And I can't install wine-stable, as it tells me to install wine-stable-i386, which I also can't install because:

 wine-stable-i386:i386 : Depends: libc6:i386 (>= 2.28) but 2.27-3ubuntu1 is to be installed
                     Recommends: libcapi20-3:i386 but it is not going to be installed
                     Recommends: libcups2:i386 but it is not going to be installed
                     Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                 libglu1:i386
                     Recommends: libgsm1:i386 but it is not going to be installed
                     Recommends: libgssapi-krb5-2:i386 but it is not going to be installed
                     Recommends: libkrb5-3:i386 but it is not going to be installed
                     Recommends: libodbc1:i386 but it is not going to be installed
                     Recommends: libosmesa6:i386 but it is not going to be installed
                     Recommends: libsane:i386 or
                                 libsane1:i386 but it is not going to be installed
                     Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
                     Recommends: libv4l-0:i386 but it is not going to be installed
                     Recommends: libxcomposite1:i386 but it is not going to be installed
                     Recommends: libxcursor1:i386 but it is not going to be installed
                     Recommends: libxfixes3:i386 but it is not going to be installed
                     Recommends: libxi6:i386 but it is not going to be installed
                     Recommends: libxinerama1:i386 but it is not going to be installed
                     Recommends: libxrandr2:i386 but it is not going to be installed
                     Recommends: libxrender1:i386 but it is not going to be installed
                     Recommends: libxslt1.1:i386 but it is not going to be installed
                     Recommends: libxxf86vm1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I don't know how to fix this, please help.

I have also tried doing sudo apt-get install -f, but it returns

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Edit: Also did sudo dpkg --add-architecture i386
Edit2: wine-staging works

Best Answer

Do you need a version newer than what is in the baseline repos?

If not, remove the ppa you added, and just

sudo apt install wine-stable

wine-stable:   Installed: 3.0-1ubuntu1   Candidate: 3.0-1ubuntu1   Version table:  *** 3.0-1ubuntu1 500
        500 [my-local-]mirror/us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 [my-local-]mirror/us.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status
Related Question