Ubuntu – Can’t get Minecraft to run on Ubuntu

minecraft

I have installed JDK and JRE from this tutorial and have tried many methods of starting it up, yet my results are always the same. If any one could please help me I would be very grateful.

Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /home/dennis/.minecraft/bin/natives/liblwjgl.so: /home/dennis/.minecraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(Unknown Source)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at org.lwjgl.Sys$1.run(Sys.java:69)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
    at org.lwjgl.Sys.loadLibrary(Sys.java:81)
    at org.lwjgl.Sys.<clinit>(Sys.java:98)
    at net.minecraft.client.Minecraft.F(SourceFile:1853)
    at aoe.<init>(SourceFile:20)
    at net.minecraft.client.Minecraft.<init>(SourceFile:77)
    at anv.<init>(SourceFile:36)
    at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
    at net.minecraft.Launcher.replace(Launcher.java:136)
    at net.minecraft.Launcher$1.run(Launcher.java:79)

Best Answer

I play minecraft and I fixed the issue by: Using oracles version of java by using the wepupd8 teams java ppa. Follow this tutorial: http://www.ubuntugeek.com/how-to-install-oracle-java-7-in-ubuntu-12-04.html

Then try this in terminal

export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-oracle/jre/lib/i386" 

And then:

java -jar technic-launcher-latest.jar 

If that doesnt work for you, you will have to update your jwgl files by following this tutorial I wrote (included references at bottom if you would rather use them):

Related Question