Ubuntu – Cannot Create Bootable USB Drive from .iso file

12.0412.10dual-bootformatusb-drive

I've tried formatting the flash drive as FAT as well as Mac OS journaled through diskutility but still cannot successfully create a bootable drive. I'm following the directions here exactly: Create a bootable USB stick on macOS.

Environment: Macbook Pro trying to create a bootable flash drive for a Macbook Pro. 8GB flash drive. Tested ubuntu-12.04.1 as well as ubuntu 12.20 .iso 64-bit downloads. Nothing to repair in disk utility for this hard drive.

Every time I finish step 8 of the tutorial I get "file system not recognized" with the options to "initialize" meaning to reformat my drive, "ignore" or "eject."

When I try to re-inspect the flash drive in disk utility after plugging it back in I see that it has some error when I try to verify it but the "repair" button is disabled.

I just want to boot to ubuntu when my mac first starts up. How to Dual Boot Linux on Your Mac and Take Back Your Powerhouse Apple Hardware.

Best Answer

  1. Download Ubuntu Desktop

  2. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight).

  3. Convert the .iso file to .img using the convert option of hdiutil (e.g., hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso)

    Note: OS X tends to put the .dmg ending on the output file automatically.

  4. Run diskutil list to get the current list of devices.

  5. Insert your flash media.

  6. Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2).

  7. Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2).

  8. Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.imgor ./ubuntu.dmg).

    Using /dev/rdisk instead of /dev/disk may be faster If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive

  9. Run diskutil eject /dev/diskN and remove your flash media when the command completes.

  10. Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.

there!

Related Question