Ubuntu – 14.04 –> 16.04 failed; apt (>= 1.0.1ubuntu2.13)’ is not installed


(This question was not resolved. Due to time constraints Computer was restored to factory settings.)

I was attempting to upgrade from 14.04 to 16.04, but apt threw this error:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

What does this mean, and how can I fix it?

When I type in the command apt-cache policy apt

Shageenth@shageenth-Inspiron-3451:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 

The error happens when I run the command:

sudo do-release-upgrade -d

and it produces the following:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

Best Answer

I've had the exact same problem today. Make sure your version is the latest Ubuntu 14.04 version before the upgrade. (Ubuntu 14.04.4 at this time)

Mine was stuck to Ubuntu 14.04.3 due to a bad mirror.

So first run:

sudo apt update
sudo apt dist-upgrade

Make sure the version is now Ubuntu 14.04.4 (update September 2016 : Ubuntu 14.04.5).

cat /etc/lsb-release

And start Ubuntu 16.04 installation with

sudo do-release-upgrade -d