Word – MS Word: There is no table of content to update, though there is

microsoft wordtable of contents

I have a document which requires precise page numbering, formatting etc. through different sections. (I'm really not used to do that kind of things.)

One problem is:
Table of content is not updating.

I inserted a Table of Contents from the References tab. It's generated with default values. When I click on the "Update table" button associated with the table, I get the message

There is no table of contents to update. You can insert on from the
References tab.

If I clik on the other button and then on "Remove Table of Contents", it removed the "Table of Content" (one might have expected something like "There is no Table of Content to remove", but no…)

I though that maybe this happens because I placed it in a different document "Section" than where the Headings 1 (so far the only Headings in the document are "Heading 1") so I tried inserting my Table of Contents in the same "section" but behaviour is still the same.

How do I get my Table of Content to update?

(Document cannot be transferred.)

Best Answer

I had the exact same problem for a while. The only workaround I found was to insert a new Table of Contents just below the existing one using the "Classic" template. Wouldn't work with any other template.

Will be annoying to reformat to the style I want but better than manually filling in the whole table.