Windows – Why won’t Windows Server 2008 R2 detect the hard drive


I'm attempting to install Windows Server 2008 R2 on a development machine but the Installer refuses to see the hard drive. I'm booting off of a USB thumb drive and the installer loads fine but after selecting the OS version it says "No Drives were found. Click Load Driver to provide a mass storage driver for installation."

The motherboard is an MSI 785GM-P45 with an AMD 785G Northbridge and SB710 Southbridge. The hard drive is a Western Digital WD10EARS 1TB SATA with Advanced Format. The hard drive is detected in the BIOS and I've verified that it works by booting off of it with another OS installed.

I've tried the driver package from MSI as well as directly from AMD. I've even tried download individual drivers from here. The installer will detect certified drivers but after loading them it fails to detect the hard drive.

I've gone into the BIOS and set the SATA controller to AHCI, RAID and IDE modes and attempted to load the correct drivers to no avail.

I'd read somewhere that this can occur if your installation media is corrupt so I downloaded the ISO from Microsoft and rebuilt the thumb drive but still get the same error.

I'm kind of at a loss as to how to proceed. Has anyone ever encountered this problem before?

Best Answer

This Microsoft Support article contains many suggestions for solving the problem:

You cannot select or format a hard disk partition when you try to install Windows Vista, Windows 7 or Windows Server 2008 R2

Related Question