Windows – Unable to select printer as default (Error 0x00000709​)

printerwindows 7

Technical Question Guys: HP P1102w printer on Windows 7.

On "device and printers" I got a list of printers but do not have a "Default printer". If i set one out as default it gives me 0x00000709. I found 2 possible solution but it's not working.

Solution A.) 1. Click Start and select “Devices Printers”2. Right click on the name of your printer and select “see what’s printing”3. In the que view, select “Open As Administrator”4. Then select “Set As Default Printer” on the main menu, note if it is already opened up as administrator, then you may not see the option to open it as administrator.

Problem here is I can find the "Open As Administrator". Note the user profile says it is already a local Admin.

Solution B.) Regedit -> HKEY_CURRENT_USER -> Software->Microsoft->Windows NT->Current Version->Windows
One of the entries you should see in the right hand pane is“Device”. If the value for “Device” as noted under the “Data” area is anything other than the printer you are using, then highlight “Device” in the right hand pane with the mouse and press the delete key to remove it. (I edited it and put the name of the printer I wanted to be the default). Restart the computer so it starts with the altered Windows system registry.

Problem here is the values I need to put "name,string,NE03:" ??? The printer is named "Frank on printserver01"

The rest of the 12 users have no problems.

Any suggestions on how to fix the problem?

Best Answer

This error can be resolved by fixing the NTFS permissions for this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

May I redirect to the following HP website which has the instructions on how to reset the Permissions (to Full Control) for the above key.

Related Question