Windows – Recent Downloaded Emails Not Showing in Inbox folder Outlook 2010

emailmicrosoft-outlookmicrosoft-outlook-2010windows 7

I have searched the web and spend hours trying to figure out this strange behaviour of Outlook 2010,

My client has this problem with her Outlook 2010 since yesterday, the mails download but do not appear anywhere in Outlook 2010. The download bar shows mails are downloading, mails are then removed from the server, but no where to be found in Outlook.

There's 1 email account, and then 5 PST files of which one belongs and is linked correctly to the email account.

I can also search in outlook for the mails, but nothing shows up, I also re-indexed Outlook and still can't find the mails. I tried sending a mail which sends fine, the mail is also stored in the sent items, so the problem is only when receiving emails

The solutions I've tried and found on don't help with my problem, I tried the following solutions on the link above

File>Account Settings>Data Files>Select the email you want to see the
emails from and click "Set as Default" then restart out look and the
inbox should have your emails in them if not hit send and receive.

In Outlook 2010, Go to "View" tab, Under "Change View" change the
Views, that will reset the settings you have.

More on the filter solution. If you are not showing a "filter applied"
indication in the lower left corner, try this. Highlight your inbox
and select the view tab at the top. Next click on View Settings on the
ribbon and select Filter. Select the Advanced tab at the top of the
window and if you see a filter set under the Find items that match
these criteria then remove it. Click OK out of all the screens and you
should see your phantom e-mail appear in your Inbox. Hope this helps

Also tried to run outlook /cleanviews with no effect

No anti virus system is installed, so that can't block mails

Operating System: Windows 7

Outlook : MS Outlook 2010

Any advise help would be highly appreciated, the client also can't afford to loose the mails, so deleting accounts etc is risky.

Best Answer

This worked for me with Outlook 2010.

1) In the left hand navigation pane, click on (highlight) the .pst file where the "missing" emails should be showing. Or, if the emails are just "missing" from a folder or subfolder, click on that folder or subfolder.

2) Click on the "View" tab on the top of the Outlook window.

3) On the far left side of the ribbon in the "Current View" section, click on "Change View."

4) There should be 4 options:

 Hide Messages

5) "Hide Messages" is probably the option presently applied, so click on the option you would prefer instead, and your emails should appear in your email window in the format you have just selected.

6) If "Hide Messages" does not appear as an option, click on any option other than the one presently applied and let the drop down box disappear. Your emails should appear in the email window in the format you have just selected. Then click on "Change View" again and choose your original format (assuming that this format is still what you want), or choose another option altogether. Your emails should now appear in the email window in the original or newly-selected format.

Related Question