Windows – OpenVPN, install a TAP adapter

network-adapteropenvpnvpnwindows 7

When I try to connect to my work VPN using OpenVPN, the connection fails with the message:

All TAP-Win32 adapters on this system are currently in use.

Many sources suggest to look in Control Panel\Network and Internet\Network Connections an enable the TAP adapter, but when I look there, there is none. Now I've run addtap.bat which is provided with OpenVPN, but I still don't get to see any TAP adapter, and logging in in VPN still fails. The output of addtap.bat is

C:\Windows\system32>"C:\Program Files (x86)\OpenVPN\bin\tapinstall.exe" install
"C:\Program Files (x86)\OpenVPN\driver\OemWin2k.inf" tap0801
Device node created. Install is complete when drivers are updated...
Updating drivers for tap0801 from C:\Program Files (x86)\OpenVPN\driver\OemWin2k
Drivers updated successfully.

I've Run As Administrator both the setup of OpenVPN and addtap.bat.
I've run deltapall.bat to remove any (maybe hidden) adapters. It said it removed three of them, after which I ran addtap.bat again to try to create another one.
I also run OpenVPN itself as administrator. What's wrong?

Running Windows 7 Home Premium on a HP Pavilion dv7 4050ed. It has worked before, but I recently had to reinstall my laptop, for which I used the restore disks I created when I just got it. Everything else seems to work fine.

== UPDATE ==

The TAP adapter is found in Device Manager, but apparently it is disabled because it is incompatible with Windows 7 64bit. I've deïnstalled OpenVPNGui, downloaded a version that should be 64bit compatible, and installed that. Still no cigar.
Then I found a tip to install OpenVPN (version 9) after installing OpenVPNGui, because that installs OpenVPN version 8. Now I got a v9 TAP driver in Device Manager, but it still doesn't work and shows up in device manager with an exclamation mark, and not at all in my network devices.

Best Answer

I was experiencing the same problem. What worked for me is to install the latest version of the OpenVPN GUI (openvpn-2.0.9-gui-1.0.3-install), reboot, stop OpenVPN, then install the latest version of just OpenVPN (openvpn-2.1.3-install) over the top of the original install. Make sure to do these installs with administrative rights.

The method is documented here:

Related Question