Windows – Network scanner occasionally not found on Windows 10

printerscannerwindows 10wireless-networking

I have a WiFi-connected printer and scanner (Canon MG 5700) that I use from Windows 10. One of the nice features of Windows 10 is that I never had to install any drivers or bloatware to get it working. Windows automatically discovered the printer on the network, and it actually works.

Not only can I print, but I can also scan using the Windows Fax and Scan application.

Occasionally, however, it stops working. When I try to scan something, I get this error message from Windows Fax and Scan:

No scanners were detected. If a scanner is installed, make sure that it is powered on and connected to the computer, and then try again.

This happens even though the scanner is, in fact, powered on, and, according to its own little display, connected to the WiFi.

If I reboot my Windows 10 laptop, it works again, so I'd suspect that the problem is in Windows, and not with the printer.

Sometimes, it's a bit of a bother to have to reboot the computer, so I'm looking for a way to resolve the problem that doesn't involve a reboot. I've tried to close and restart the Windows Fax and Scan application, but that doesn't solve the problem. I've also tried to disconnect from, and reconnect to, the WiFi, but that also doesn't help.

If there's some Windows service or other kind of daemon I could restart, I'd consider that an improvement over rebooting, but I haven't been able to figure out which one to target.

Is there a (fairly) easy way to 'reset' Windows 10 scan and printing so that it discovers that the scanner is, in fact, online?

Best Answer

I have an MG7150 and restarting the Windows 10 service Windows Image Acquisition (WIA) AKA stisvc did the trick. I had to restart it three times, so I guess some randomness is involved. The last time it refused to be stopped and I had to manually kill the process. To kill the correct svchost.exe process, add the Command line column in Task Manager's Details tab and find C:\WINDOWS\system32\svchost.exe -k imgsvc

The solution is really thanks to the comment by Thijs van Dien. Before I found that I had already tried several things. Including moving the printer to the wired network, but I don't think that makes any difference.

Things that did not work:

  • Having the printer on the non-public WiFi network (I would imagine not being on the publi WiFi is a prerequisite, though)
  • Moving the printer to the wired network
  • Reinstalling the printer (which I had to do when switching network and getting a new IP address)
  • Settings -> Printers & scanners -> Manage -> (dropdown) Scanner: MG7100 series _id -> Scanner properties
    • This gave me the Scanners and Cameras dialog with an empty list
    • Add Device... -> WIA Scanner Device seemed promising, but achieved nothing
    • MG7100 series _id showed up automatically after enough stisvc restarts
Related Question