Windows – Local disk: “These files might be harmful to your computer”

hard drivelocal-storagepopupsSecuritywindows 10

When moving or copying files from my local harddisk, I get the message:

These files might be harmful to your computer. Your internet security
settings suggest that one or more files may be harmful.

This happens when I move or copy files on the drive (D:) itself, or when I move/copy files from that drive to any another drive on my pc. All the drives are local installed in my case and connected with sata cables.

How can I disable or fix this pop-up message?

I am running: Windows 10, Version 1511,Os Build 10586.164, It's my own build machine. (I have seen a lot of similar posts, but in my case I am not transferring files over the internet)

Update

It has been a while I posted this question, and I still have this problem. I tried the suggestion from @manjesh23, but this did not work.

pop-up

Best Answer

I found a fix by changing "internet options" -- so I guess Windows is detecting the "internet" as my own network.. sigh.

  • Click Start / Control Panel / Internet Options
  • Click Security tab.
  • Click Local Intranet
  • Click Sites button.
  • Click Advanced button.
  • Enter the IP Address of the other machine or server (wildcards are allowed) and click Add
  • Click Close, then OK, then OK again.

Changing Internet Options screenshot

This worked for me, but it's a bummer I have to manually enter IPs here.. it would be nice if Windows could detect this is a local network file copy and skip the irritating (and pointless) warning about "dangerous" files.

Source:

Related Question