Windows – images blocked in Windows Explorer Preview Pane when viewing saved webpages


When I try to view saved web pages (with .html extension) in the Windows Explorer preview pane, I often see this message: "Some pictures have been blocked to help prevent the sender from identifying your computer. Open this item to view the pictures." Is there a way to prevent the blocking of the pictures?

Best Answer

This is to help protect you against potentially malicious functionality accessing your computer. When the html is located locally on your computer, it is possible for the server where the images is located to read certain details about your computer. This warning is a good thing - if you trust the original site where the pictures are located, you can choose to allow it (after the warning). You would think that static images can not do harm, but images can be created dynamically on the server, and in that case, the image url is a call to a server function that returns the image response after doing some stuff on the server. The server process can read some information from the parent web site (which in this case is your computer).

If you want to get rid of the warning, you must save the complete web page, not just the html. You have 2 options in the Save as... dialog in IE that does this:

Web page, complete (*.htm;*html)

This stores the html, and also all related resources (images, css files, js files etc) in a separate folder on your computer.

Web Archive, single file (*.mht)

This stores everything inside a single file, that can be read by IE. This stores all resources within the file as binary data.

Related Question