Windows – Enter BIOS Setup on Lenovo G580

biosbootlenovo-laptopwindows 7

I have installed Windows 7 on my Lenovo G580 laptop.

To enable Intel Virtualisation Technology, I need to go to BIOS.

When I start my laptop, it displays press F2 to enter BIOS Setting, F12 for Multi-Boot Menu.

When I press F2, instead of going to BIOS Settings, My laptop prompts for recovery of Windows 7.

Tried many ways by long pressing F2, Combination of Fn + F2, Installing BIOS Update, Nothing worked so far. I also tried pressing F2 repeatedly and quickly immediately after turning on the laptop. It goes to the Windows 7 Recovery Screen.

Best Answer

My first recommendation would be to press the button tho the right of the power button, while the computer is shut off. I believe it should come up with a menu to be able to go into the BIOS setup. I have a Lenovo Y50-70 and my "Novo Button Menu" appears when I press it.

If that does not work, please check this guide. It may just be the way it boots, or you may have enabled the "fast boot up" option in BIOS, in which(from my experience) it would not let you go into your BIOS