Windows – Can’t see emails older than one year in Outlook 2010


I'm using Outlook 2010 on my office and home computer and have setup my email as IMAP on both.

I can't see emails older than one year.

I have tried to check the setting on both computers but can't figure out why. I don't want to archive or lose my old emails unless I delete them manually.

Best Answer

Outlook 2010 uses the Auto Archive feature to keep Outlook running smoothly. It automatically stores old items outside of the Outlook Data file which meet the settings criteria you were looking at. It does not delete them (unless you choose to do so). It only store them in a seperate location.

To access archived items and to learn more about how to use it, here is more detailed information.

Related Question