Windows – Can’t boot computer after enabling Client Hyper-V

boothyper-vwindows 10

I have a CyberPowerPC with an Intel chip that supports virtualization. I noticed that VirtualBox is somewhat sluggish with GUI virtual machines so I decided to enable Client Hyper-V to see if that worked better. I followed the powershell instructions here. After reboot my computer wouldn't get past the three dot wheel before going to a black screen and rebooting.

I subsequently found a recovery boot screen that allowed me to boot into safe mode. I used safe mode's power shell to disable Client Hyper-V. Upon restart the system went back to normal mode without my re-enabling it (I guess that's default behavior?) and still wouldn't boot.

I checked to make sure virtualization was enabled in UEFI and it was. I tried disabling it. Still no good.

After attempting to get back into Safe Mode the computer went straight to a Restart Screen and now I'm back in normal mode.

Please Help. I don't even know how to consistently get into safe mode. I can't even reach a login screen unless it's in safe mode and I don't know how to consistently reach safe mode. My boss is in the other room and doesn't' know about the trouble I'm having. My stomach is in my throat. Panic

Right now I'm in safe mode attempting a data backup.

UPDATE: More data:
Processor Intel Core i7-3820 @3.60 GHZ, 16 GB Ram, 64-bit Windows 10 Pro

Problem: Enabled Client Hyper-V via PowerShell and rebooted when prompted. Boot process reaches dot circle loading screen before cutting to black and auto-rebooting in reboot loop.

Troubleshooting Steps taken:
1) Booted into safe mode, disabled Client Hyper-V via PowerShell. Rebooted when prompted. Booted into normal mode. Result: Still see dot circle loading screen cut to black auto-reboot loop.

2) Disabled virtualization in UEFI. Result: Same

3) Re-enabled virtualization in UEFI. Result: Same

4) Booted into safe mode to backup all data. Hyper-V appears unchecked in 'Turn Windows Features on/off' menu.

UPDATE2: I noticed in msconfig.exe that there are several services labeled Hyper-V. I unchecked all of them and performed a normal boot. Result: same.

Best Answer

Did you ever sort this out? I just ran into the issue while trying to run Docker in Windows 10 x64.

It's definitely being caused by Hyper-V, but I haven't discovered exactly why or how to fix it yet. What I have found though in the meantime to still be able to boot into Windows (not just Safe Mode, and obviously without Hyper-V being usable once booted) is to toggle off Hyper-V via your BCD file.

You have to be able to get to a command-line though. What I've been doing is wait for startup repair to fail, then boot into Safe Mode. From there I open up an elevated (Admin) Command-line and type this:

BCDedit /set hypervisorlaunchtype Off

Then reboot.

If you have more than 1 item in your BCD you might need to specify which item to turn hypervisor off on. You can view all BCD items just by typing:


And to specify the item to alter, just add in its ID:

BCDedit /set {<long string of numbers here>} hypervisorlaunchtype Off

NOTE: When installing Hyper-V, it apparently automatically sets that flag to "Auto" (on) in your BCD, which causes the BSOD/Boot Repair Loop. Once you get the problem sorted out, you'll need to set that flag back to "Auto" to use Hyper-V again. I always make 2 boot choices in my BCD; one with Hyper-V enabled, one with it disabled. Then I select the one I want as needed.

Related Question