Windows – Cannot end Windows 7 process, even tried ntsd


As descriebed in My VirtualBox virtual machine freezes, when I try to use the webcam, I end with a process which can't be deleted by taskmanger, pskill nor even ntsd, which was recommended here.

BTW. ntsd is not part of Windows 7, but I could download it with the Debugging Tools for Windows 64-bit Version.

Best Answer

This most probably indicates that the related hardware driver or the hardware itself is buggy. As mentioned in the Old New Thing blog (linked in the Cannot end Windows 7 process, even tried pskill question):

In other words, if a process hangs around after you've terminated it, it's really dead, but its remnants will remain in the system until all drivers have cleaned up their process bookkeeping, and all open handles to the process have been closed.

I've seen this problem happen in drivers that I wrote myself (during debugging), and the only way to handle this is to unlod the problematic driver and hope that it will clean up after itself on unload:

  • Disconnect the hardware (e.g. unplug your USB webcam) OR do net stop drivername for software-only drivers, if they are loaded on-demand.

If you cannot do this, or unloading the driver fails, then only reboot option remains.

Related Question