Windows 8.1 Display Driver Gone? Black Screen on Boot and Safe Mode

black-screen-of-deathdisplay-driverwindows 8.1

I've got some really weird problems with my computer. It's the Asus G750JX Notebook.

To clarify;

  • I've got one 256 GB SSD(Windows is on a 90GB partition) and a 1TB HDD(which I installed by myself).
  • I'm running Swedish Windows 8.1 64-bit

The Problem

I get a black screen after Windows logo is shown on boot, even in safe mode.

I was playing around in Photoshop when I noticed that the contrast on my monitor changed when I turned on/off a layer containing dark elements. I searched the internet for a solution when I found out that it might be a setting in the Nvidia control panel.

I opened my system tray and right-clicked on the Nvidia icon. I proceeded and clicked on the Nvidia Control Panel and waited for a minute or two. Nothing happened. I tried and failed once more. I got a bit frustrated and found the file path in explorer and tried to open it as an administrator, still without any luck. I found a forum post with the same problem and some people said that he should make a clean install of the display drivers.

I checked if my display drivers were up to date through the Nvidia Experience software and on their website. Both said that my drivers were up to date. The posts on the forum recommended a software called Display Driver Uninstaller(DDU) to properly uninstall the driver.

I downloaded DDU from a website called I placed it in my downloads folder and extracted it. When I opened the .exe it said that it was recommended to uninstall the driver in safe mode. It asked me if I wanted to restart and go into safe mode and I pressed "Ok". The computer restarted, the Republic of Gamers logo appeared(Asus replaced the Windows logo) and then there was just a black screen. I waited for like 20 minutes but nothing happened.

I force shutdowned the computer by holding the power button and turned it on again, just to be greeted with the same black screen. I searched the DDU forums but didn't find anything of interest.

After hours of scouring through threads with similar problems I still didn't find any solution.

What I've done to try and fix it

  • Restarted the computer like 100 times(mainly to try and get into the BIOS settings and Boot menu)
  • Looked at guides and reading forums for hours
  • Turned off my computer, waited for more than 10 seconds, removed the battery and then started it again.
  • Kept my computer shutdown for >1 hour and tried to start it again.
  • Reset my BIOS to default settings
  • "Refresh your PC" through boot menu
  • Automatic reparation through boot menu
  • SFC Scannow in command prompt through boot menu
  • Change the start behaviour in boot menu

Some notable things

  • I haven't(to my knowledge) uninstalled the display drivers yet, DDU just told me to boot into safe mode.
  • The Safe Mode doesn't work, it's just a black screen with "Safe Mode" appearing for a couple of seconds in the corners.
  • Whenever I fail to get into the BIOS settings or the boot menu by pressing F2 and F8 at startup, the mouse sometimes appears on the black screen. I can control it, but when I let go, it disappears and returns to the middle of the screen.
  • The "Refresh your PC" tells me there's not enough space on the SSD. Update Now it says:

    "The drive where Windows is installed is locked. Unlock the drive and try again."

  • The Automatic Repair fails every time and created a log file on the desktop
  • The SFC scannow says:

    "Windows Resource Protection could not start the repair service."


I have no idea what to do anymore. I don't want to do a full recovery since I've got some valuable files on my drives. Though, if that's the only solution, is it possible to remove the HDD(my most valuables files are on the HDD) before doing a full system recovery?

I would really appreciate any help! I've managed to get into the boot menu once more and I'm not leaving it yet…

Best Answer


I've had my computer in the Windows Boot menu the whole day. I had lost all hope and was going to do the "Reset the PC" in the boot menu. Since I've got two drives I was unsure how to proceed, so I opened another thread here. I turned off my computer and was going to try and start it once more before reset. The Republic of Gamers logo appeared as usual and for a moment it was just black as before. But then, ten seconds later, the login screen appeared and allowed me to login.

I'm writing this on my computer :o This is the most odd problem I've had with a computer. Gosh. Anyway, I'm closing this question(though, I'll keep my other question up since I want to know the answer to that).

Related Question