Windows 10 Wifi Limited Connection – Wi-FI doesn’t have a valid IP configuration

windows 10wireless-networking

Wifi was working via router in my house. Took it round to my friends house and it says Limited Connection.

Wireless network adaptor is Qualcomm Atheros QCA61x4 and current driver is I tried updating (via GUI) this but it says I have the latest driver.

If I run Windows Network Diagnostics, it attempts to reset the wireless adaptor, and results in the following problem:

Wf-Fi doesn't have a valid IP configuration - Not Fixed

Running ipconfig /release prints:

An error occurred while releasing interface Wi-Fi : The system cannot find the file specified

I am finding that the problem is intermittent. I have just restarted the computer when it wasn't working and now the Wi-Fi connection is working.

Best Answer

Reset your TCP/IP:

  1. Press your Windows-Key
  2. type cmd into the search programs and files field
  3. right-click the result and run as administrator
  4. in the following window type first: netsh winsock reset followed by pressing return - you will be told that you have to restart your computer; ignore it for the moment
  5. type netsh int ip reset followed by pressing return
  6. close the cmd window and reboot

If you had a static IP you would need to set it again.

Related Question