Windows 10 can’t resolve hostnames – ping with IP works but not with hostname

dnsipnetworkingpingwindows 10

Facts:

  1. The browser doesn't load any pages, whether they are addressed with IP or hostname.
  2. ping google.com doesn't work, returning Ping request could not find host google.com.
  3. ping 216.58.209.78 (google IP) does work, sending and receiving all packets.
  4. nslookup google.com does work, returning correct IP address that then does indeed work with ping.
  5. Network settings are default, IP and DNS are set to auto.
  6. Specifying OpenDNS in network settings does not help.
  7. There are no entries in c:\windows\system32\drivers\etc\host
  8. There are no DNS prefixes in use.
  9. netsh winsock reset & netsh int ip reset does not help.
  10. DNS client is running.
  11. The most common given solution on the Internet ipconfig /flushdns & ipconfig /registerdns does not work, with latter returning Registration of DNS records failed: Parameter is not correct. It happens occassionally to people, but I have not found possible solutions to this problem. I sense this might be the key to my ordeal.
  12. All of the above happens for different networks.
  13. The PC has been recently formatted. One guy had the same problem and it helped to restore the previous PC name, but I have no way of finding what the name was before the format.
  14. ipconfig /all is as below. The first paragraph looks a bit blank, perhaps something there…?

    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : 
       Primary Dns Suffix  . . . . . . . : 
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
    
    Ethernet adapter Ethernet:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 2C-60-0C-9B-A8-89
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    
    Wireless LAN adapter PońĄczenie lokalne* 2:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
       Physical Address. . . . . . . . . : AE-E0-10-65-58-B9
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    
    Wireless LAN adapter Wi-Fi:
    
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Karta sieciowa Broadcom 802.11n
       Physical Address. . . . . . . . . : AC-E0-10-65-58-B9
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::fc42:138f:fb5a:f6ff%12(Preferred) 
       IPv4 Address. . . . . . . . . . . : 192.168.0.172(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 21 grudnia 2015 22:16:55
       Lease Expires . . . . . . . . . . : 28 grudnia 2015 22:21:43
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DNS Servers . . . . . . . . . . . : 217.172.224.160
                                           192.168.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Tunnel adapter isatap.{9E3DA69D-E183-4041-9944-35B59277B529}:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    
    1. Setting DNS to 8.8.8.8 doesn't work, see replies to suggestions beneath.

    2. It doesn't resolve local hostnames either. The machine doesn't respond to pings from local network.

Any ideas how to proceed? Help my dad enjoy his internet!

Best Answer

a. You can try to manually set the dns servers to the google ones: 8.8.8.8 and 8.8.4.4

b. You can try another wireless adapter

c. You can try a linux live cd and verify if the issues are still present

Related Question