Why all the sudden I cannot access a remote SVN


I am working for a company remotely. The SVN server is running on their site. I access it from my home remotely for several months.

Yesterday morning I found I cannot access the SVN server. They were using port 540 before and they found that port is not available anymore. But don't know why. I can ping them without problem. Their SVN server is working internally within their local network.

Then they changed the port to 5400. It allow access from outside now but not me. I asked my friends to access that port which also has a webpage, they all can see that webpage but I cannot. I always get timeout.

I have restarted my entire home network many times. My home network is consist of a SB6120 SURFboard DOCSIS 3.0 Cable Modem, a NETGEAR ProSafe VPN Firewall FVS318 router and a TRENDnet TEW-452BRP wireless router.

I have two machines, a win7 and a Linux. Both are the same result. Most of time I am using wireless but I tried the wired cable connection. No difference.

There is no other abnormal networking activities found.

How can I find where is the issue?

I think the issue is on my side because my friends from CA and NH can access that site.


Now I am in the public library. I can access that site now from here.

Best Answer

Sounds like a firewall issue somewhere. Possibly because 5400 has been associated with trojans previously.

Check your router firewall for exclusions. Try manually adding an exception for 5400.

As a last-ditch attempt you could also try putting your linux machine address as a DMZ in the router (forward all traffic) just for a temporary test. I'd not advice this.

Related Question