Way that I can tell IE9 to stop running in IE9-Compat View for “Local intranet” sites

compatibilityinternet explorerinternet-explorer-9website

I have a site which only functions in IE9/Chrome/Firefox. The site is an internal only site from a vendor, so we access it by https://serverName/ — IE9 correctly identifies this as an intranet site, but for reasons I cannot explain it is reporting it self as IE8. The site sees this and won't let me log in.

Is there a way that I can tell IE9 to stop reporting itself as IE8 for this site?

For the record, the software is PRTG Monitoring… so if there are other ways to work around it I'm good with that too.


This is what I see when I open the site:

enter image description here

If I change Browser Mode from IE9 Compat View to IE9 and refresh, the website works as expected. As you see here, I have no Compatibility View button in my address bar to change. I had to go to the developer tools to switch modes. This only fixes it until I close and open the browser again though.

If I access the site by its local IP address instead of https://serverName/ IE correctly runs in the right mode and the site works fine.

Best Answer

In the Tools menu on the command bar there is an entry that brings up the Compatibility View Settings dialogue. Ensure that the "Display intranet sites in compatibility view" checkbox is unchecked.

Further reading