Windows – Using keyboard disables touchpad left button for a second on Acer laptop in Windows 8.1

driverskeyboardmousetouchpadwindows 8.1

The problem is present in the whole system not only in games: desktop, chrome, games, everywhere.
When I press any "input key" on a keyboard for example in desktop I can't select the file by left mouse button OR by tapping the touchpad for about one second(right button works immediately). Later on the LMB works well. There is NO delay, button is just deactivated for a second. In games that means that when I run I cannot shoot for example.
When I switched LMB and RMB functions in windows control panel still the LMB is getting disabled and RMB works fine.
By "input key" I mean letter or a number, keys like Alt, CapsLock, Ctrl does not affect touchpad. I do not remember that problem when I used Windows 7. USB mouse works like it should.

The problem existed when I was using Elantech touchpad driver and after I uninstalled it and used Windows 8.1 generic driver.

I installed the Elantech drivers and set values to 0 at every disable... key. But the problem is still present.



I have turned off disabling function in touchpad but it did not fix it. I know that touchpad is NOT broken down.

  1. Turned on the animated touchpad icon of elantech drivers and put it on the task bar(on a picture)

  2. When I type the letter and press the LMB the dynamic icon displays the click but it is ignored.
    enter image description here
    enter image description here
    enter image description here

Best Answer

This solved the problem for me with my ElanTech Touchpad on my Asus G55vw laptop:

Mouse to right hand corner > Settings > Change PC Settings > PC & Devices > Mouse & touchpad

Change the "To help prevent the cursor from accidentally moving while you type, turn off taps or change the delay before taps work" setting to "No Delay (always on)".

For some people this option is apparently grayed out. In that case the setting can be adjusted via a registry value. Go to the below registry value:


And change "AAPThreshold" from 2 (or whatever setting it's at) to 0.

You may have to reboot for it to take effect.

Nothing in the third party driver for ElanTech solved this issue. I honestly think this was some new setting introduced in Windows 8.1 for touchpads.

Related Question