Windows – Unable to try or install ubuntu 12.04 and above 64 bit on the Sony Vaio which includes UEFI and Secure boot

bootsony-vaioUbuntuuefiwindows 8

First of all the hardware :

  • Core i5 Ivy bridge 3210M 2.5Ghz
  • 6Gb RAM
  • AMD Radeon HD 7650M
  • 750Gb HDD

With Windows 8 Single language 64bit preinstalled.
And include UEFI and Secure Boot

Specific model number – SVE15128CNS

Problem :
I am trying to "try ubuntu without install" with a live USB on my laptop, but I was unable to. I ended up getting a blank splashing screen with nothing on it, which forces me to shut down using power button.

I used nomodeset but still nothing. I could not reach the graphical interface or a good terminal where I can do something useful. I have tried with secure boot disabled, but couldn't change UEFI to legacy as windows 8 is pre-installed. I have tried with the following operating systems:

  • Ubuntu 12.04
  • Ubuntu 13.04
  • xubuntu 12.04

How can I try Ubuntu without installing it on my machine?

Best Answer

Finally i am able to find the solution for my own problem. And, it is as follows:

First of all the main problem according to my diagnosis:
Problem was related to graphics because i think the proper drivers were missing.

Now the steps i took:

  1. Disable secure boot feature in BIOS. And already created a 40gb partition on my harddisk. Didnot create any EFI partition because it was already there as i have windows 8 preinstalled.
  2. Attached my Laptop's VGA to a bigger screen size, and i think this was the best step to solve the problem, as i was able to view the regular xubuntu screen on the bigger screen while my laptop was still showing nothing except continuously flashing.
  3. Booted my laptop with a live USB stick. And got three options to choose from:
    • Try Xubuntu without installing
    • Install Xubuntu
    • Check disk for defects
  4. I chose Try Xubuntu without installing just to check that if the bigger screen tweak is working or not and it did work.
  5. Now i chose to install xubuntu from the live USB's desktop. And everything went as usual, i.e in the regular way when we install ubuntu or xubuntu on our systems, but everything was visible on the big screen not on my laptop's.
  6. Finally Xubuntu installed and was working but the screen was visible on the big screen not on laptop's. So, here comes the workaround for getting things visible on laptop's screen:
    - I downloaded the latest drivers from AMD's official website for my laptop's graphics card for linux 64bit edition (the file was in .run format) and installed it on Xubuntu and the installation was pretty smooth without any errors. After installing the graphics driver and rebooting the system, finally! i got the laptop's screen working, but there was still a trick left to do as the graphics on the screen was tearing so i did this:
    - Applications menu >> Settings >> AMD catalyst control center >> Display options >> Tear Free >> Enable tear free desktop to reduce tearing >> Apply. And here, i am done. After this everything is working just fine and as usual and i am having a perfectly working linux system.

    Note : But as i was having a working linux system my windows 8 won't boot so to solve this i used boot-repair on xubuntu, and followed the instructions on the linked website for getting, installing and executing boot-repair and thus ended up solving this problem also. So, now i have Xubuntu and windows 8 dual boot without any problem.

    Note : One more thing, to boot windows8 from grub2 menu after using boot repair use "Windows UEFI Boot Loader" as nothing else works to boot windows 8.

I have tried this only on my laptop and can't be sure about other company's system or laptop but it is worth trying if you face problem similar to mine because it doesn't include any complex operation which can possess danger to your system.

Related Question