UEFI Legacy boot hidden – tricks to unlock it

biosbootuefiusb

I bought an Acer Aspire E1-510P-4459 with Windows 8.1… And I am considering installing Linux on it; maybe Win7, but I'd need to get a USB CD for that. So I downloaded a live image of my favourite distro: Crunchbang, but I can't for the life of me, make a UEFI-bootable USB stick from it.
Tried both dd (Cygwin 6) and Rufus (MBR for BIOS/UEFI since I want it to be bootable for both).

So I opted for the next best thing: since I am not intent on keeping Win8.1, I don't need UEFI at all. Rebooting into the BIOS to disable it, I find the CFM/Legacy option is hidden from me. Even the Secure boot was greyed out and could not be disabled. Fortunately, I was able to get control of the secure boot by adding a password to my BIOS. But Boot Options still had only UEFI.

I am not too familiar with Windows 8.1, but in my quest for an answer I did find tricks that other people have used to unlock their UEFI settings, but none of them gave me a legacy boot.

I have already tried using the Advanced Startup "Use EFI USB" feature, but it says it isn't finding anything bootable… And going into UEFI settings from that advanced startup does not boot me into this: http://www.eightforums.com/attachments/tutorials/16543d1360707770-uefi-firmware-settings-boot-inside-windows-8-uefi.jpg
it just boots me into the F2 menu and gives me some more options to tweak the Secure Boot, but still no Legacy mode.

So, does anyone know of a trick to make it appear? It has to be there! I've seen it on other laptops; and given how new UEFI is, it needs to have backwards compatibility with BIOS.

Alternatively, how do I make my USB bootable for UEFI? Preferably manually, since I am sick and tired of all these tools. I know I have to add an EFI directory with an EFI shell, but then what?

EDIT: I guess I forgot to mention the USB key does boot on older non-UEFI laptops and has been booted on a laptop with UEFI in Legacy mode.

Best Answer

Problem solved. A 'BIOS' update from Acer did enable the Legacy boot mode choice.

The instructions provided in the Crunchbang forum assume you can boot the installation media... And the Crunchbang developers have yet to release an EFI-bootable image. This means that I would in fact need legacy mode to install the OS and then following those instructions, make it UEFI-bootable. So you can sleep tonight, knowing I am booting my Linux through UEFI.

EFI may have started out in the 90s, but it has only recently made its way into mainstream computers/laptops. Even Hiren's bootcd hasn't yet been re-made to support it.