Ubuntu – usb-creator-gtk hangs at 38% when making bootable USB device

bootubuntu 11.04usb

I'm using usb-creator-gtk to create a bootable USB with Ubuntu 11.04. The USB device is a SanDisk Cruzer 4 GB, and I have already used u3-tool to remove the U3 cruft that comes with SanDisk devices, and completely wiped the USB stick.

When I run the command:

 ely@AMDESK:~$ usb-creator-gtk -i /home/ely/Downloads/ubuntu-11.04-desktop-i386.iso

the usual GUI pops up. I select the 4.0 GB USB filesystem and click "create." At this point, a popup window appears that says "Installing" with a progress bar. It steadily moves to the 38% complete mark and then just freezes. If I force-quit the process, re-wipe the USB drive and re-try, I get the exact same error.

Why does usb-creator-gtk just hang with no information? How can I prevent it from freezing so I can finish the bootable drive creation process?

Best Answer

I just googled for a similar problem (stuck at 38%, but different usb drive). Turns out that after leaving it for 10 minutes, it eventually asked for sudo permissions to write the boot loader, and then got stuck at 99% for a long time ("Creating a persistence file").

Eventually it completed, but it took about 30 minutes in all. I have no idea why it takes this long (given it took 5 seconds to copy the iso in the first place) or why they can't create a progress bar that's a little more reliable.

Related Question