Several USB ports stopped working


Yesterday I installed Ubuntu 14.04. I got to mess around with the OS a little bit, but I then got curious and decided to plug in my USB charger for my Samsung Galaxy Note 3 in one of my back USB 3.0 ports. I wasn't paying attention, so I accidentally touched the wrong end to the USB port for not even a second, when I got a screen with red and pink stripes.

enter image description here

I then had to force shutdown my computer. As it was turning on, I pressed F9 a couple times so I could boot into Ubuntu again, only coming to realize that my wireless keyboard doesn't work. I waited for a little until it got to the usual Windows 7 login screen, now finding out that my wireless mouse doesn't work either. They were both plugged into 2 of the 4 USB 3.0 ports in the back as mentioned earlier.

I finally found my PS/2 keyboard, which works fine, and I plugged in the mouse into one of the front USB ports, only one of which worked. Now I have no open USB ports, my computer has no wireless card (I use PDAnet for internet connection), and my phone can't connect to the computer (no open ports that will recognize it), so no PDAnet. I cannot update the drivers now because of this. I've tried what I can (checking USB root hubs in Windows Device Manager, checking registry, etc.), but nothing is working. What can I do now?

Best Answer

If you can't fix it and your computer is a desktop computer, get a 4-port PCI Express USB expansion card. I don't think you can get one of these cards anymore in a brick and mortar store, because these cards were mostly available back when motherboards without built-in USB ports were still being manufactured, but you can get PCI Express USB expansion cards online.

Related Question