No video after installing new graphics card with VGA-DVI adapter

graphics cardnvidia-geforcevideo

Don't know if the question belongs in this site, but I'll try anyway.

I had a GF 8600GT whose capacitors blew. Nevertheless, if the card was cold, the system managed to start with scrambled graphics, but I got an image anyway.

Now I bought a brand new 9800GT (taking the opportunity to make an upgrade) and installed it. Now I have no video. The old card also doesn't give video anymore. The differences between this time and the last test I ran and got video is the monitor (which is working, because I connected it to my laptop to test) and the VGA-DVI adapter, since neither card has a VGA connector. However, neither the adapter that came with the old nor the new card works, so I'm finding it unlikely that the adapter is the problem.

So, while I don't have the conditions to try the test with a direct DVI cable, I'd like some ideas on what to check meanwhile. My impression is that either it's something simple I'm missing or something very serious that blew up another part of my setup.

Some other random facts that might be important:

  • All the coolers start properly, including the video card's.
  • The power light of the motherboard is on and the PCI-E 'problem' LED lights up if I don't connect the card properly, so I'm thinking the motherboard isn't 'too dead' yet.
  • May connecting the old card with blown capacitors (this makes it heat up very fast) even for a few seconds have blown up something?

So, I'm willing to play "House's" part and try pretty much any idea that could lead to a solution/change of symptoms. Pretty much anything is accepted.

Thanks in advance!

Best Answer

I ended up disassembling the computer ENTIRELY to dust it off and buy me some time to consider the approach I'd take.

Then while I was reassembling I tried turning it on without any video card to see if the motherboard would beep (if it didn't, then something would be very wrong with it). It did beep, and I installed the card afterwards and it worked perfectly.

So, I had no chance to try resetting the CMOS, but quack's reasoning seems very right and should be tried by anyone experiencing a similar issue.