No bootable device after changing to Legacy

biosbootbootable-mediauefi

I'm using an ASUS aspire e 15 laptop with Windows 10 and Ubuntu installed. I wanted to boot from a live USB, but no matter what, it boot even though, the same live USB works on another machine.

Boot order was set to

  1. USB
  2. Linus
  3. HDD

When I turned the PC on, I had security boot fail message.
I cannot change Secure boot to disabled because it is grayed out.

Now comes the part where I probably messed up.
I have read somewhere that I should change boot mode from UEFI to Legacy, so I did. I turned the PC on and all I had was black screen with a white horizontal blinking input line. I turned pc off again, entered into bios and changed boot mode back to UEFI.
Now when I turn the PC on, I get no bootable device message.

When I go to the boot menu, the only option I can see is USB, no more HDD available. When I unplug the USB, the list becomes empty.
In BIOS, boot priority order now misses Linus but I see HDD on first place like always.

At this point I'm too scared to go further myself. I erased both my systems with important files and projects. Can someone please help me and if possible, explain to me what I did wrong? I'm complete newb to these things.

Best Answer

If everything you have actually done is simply switching from UEFI to Legacy and viceversa, this is really odd.

It looks like you are mostly worried about whether you lost your data or not. To ensure that everything is ok (as it should be), try booting from your live USB. You can then check the contents of your hard drive from there.

Some research on the internet tells me that in order to disable Secure Boot you need to first set up a supervisor password in your UEFI firmware. That could help in booting the live USB. You usually find the options to set up a password and disable Secure Boot in the Security tab in your UEFI.

Related Question