Mac – How to stop Word 2011 opening hyperlinks on click

macmicrosoft wordmicrosoft-word-2011

In previous versions of MS Word, there was a preference for the action to be taken when the user clicked a hyperlink: open it, or edit it. Word 2011 appears to have defaulted to opening the hyperlink, and I can't find the preference to change this behaviour.

How can I change Word's default behaviour when a hyperlink is clicked to be editing the text of the hyperlink? Holding down a modifier key when clicking is not an acceptable solution, as the aim here is to prevent misclicks from causing web pages to open.

Edit: the links need to stay as links in the saved document. But when clicked on my machine, they should not open. Word needs to default to just editing the link, so an inaccurate click does not take me out of the document into Safari. Older versions of Word had a preference controlling this, and Microsoft seem to have removed it and fixed the behavior at the unsafe option in order to satisfy the point-and-drool crowd.

Best Answer

I went looking for this for the same reason - it isn't on the preferences menus anywhere. Just by chance, I discovered that if you use Ctrl+Click (the default for Windows), it doesn't open the link when you click. My links were behind pictures not words, but I would suspect it'll work the same way.

Related Question