Linux – Mint 17 and Windows 8.1 Dual Boot: No EFI partition

bootlinuxlinux-mintpartitioningwindows 8.1

I am working on the installation for Mint 17 and need to understand what is going on with my Windows 8.1 booting. Here is an image showing all partitions from Windows:

http://i.imgur.com/Xvf5OjE.png

As you can see the EFI patition is 100% free space, and "Boot" is included in the status message for the C partition.

In these instructions the author suggests changing the "efi" parition to EFI Boot partition using the "Change" option. However, I do not have an "efi" partition in under my available partitions in the Mint installation.

If I create root, home, and swap partitions, and click "Install Now" I get the following error:

The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked for use as a "Reserved BIOS boot area" and should be at least 1MB in size.

UPDATE >> It looks like I do have an EFI system partition, but Mint isn't recognizing it as such, and is not providing the option to "Change" to "EFI Boot partition" selected.

mint@mint ~ $ sudo parted -l
Model: ATA TOSHIBA THNSNS25 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  316MB  315MB   ntfs         Basic data partition          hidden, diag
 2      316MB   588MB  273MB   fat32        EFI system partition          boot
 3      588MB   722MB  134MB                Microsoft reserved partition  msftres
 4      722MB   123GB  123GB   ntfs         Basic data partition          msftdata
 5      245GB   246GB  472MB   ntfs                                       hidden, diag
 6      246GB   254GB  8389MB  ntfs         Basic data partition          hidden, diag
 7      254GB   256GB  2147MB               Basic data partition          hidden

How should I proceed?

Best Answer

Well, I figured out the issue. I created a bootable USB drive that wasn't configured to launch via UEFI. I used Rufus to remedy the problem by selecting "GPT partition for UEFI computers" when creating the USB. Once I went back into the Mint installation, I was able to change the efi partition, as suggested by the tutorial I referenced above. After re-installing Mint, there was a problem. I went straight to the grub command prompt, rather than the OS selection screen. I was able to remedy this using the boot-repair app for Ubuntu, and now have the OS screen. I deselected "secure boot" when repairing grub using boot-repair.