How to upgrade UEFI bios without battery in Acer laptop

biosbootlaptop

My laptop is Acer Aspire V5-473PG and I used windows 10 Pro 64-bit. And my battery is already dead around 1 year. Now, when I turn on my laptop, it always shows something like this : Boot media is missing, Please insert bootable media....

But, I can boot with legacy boot mode, not UEFI. So, I think my UEFI firmware has some problem and I want to upgrade my UEFI. So, I download correct BIOS for my laptop from acer website and it contains only one executable file.
When I run that file to upgrade BIOS, it shows Please insert system battery and I can't upgrade.

I already search many ways on internet, but not working. So, please anyone help me how can I upgrade my bios without battery.

Best Answer

Just got thorugh this "upgrade bios without battery" hell on my Acer E11.

The following worked for me:

  1. Download the BIOS update from Acer site (ZHK116.EXE)
  2. Run the downloaded file, you will get an error like "No battery" or "Low battery", stay on the error dialogue (!)
  3. Navigate to your current users temp directory %userprofile%\AppData\Local\Temp, there should be somewhere a temporary directory containing the extracted files from the EXE file (for me it was 7zS4A88.tmp)
  4. Save the contents of that temp directory somewhere (you can then close the error dialogue, the temp files will be removed)
  5. Open the file platform.ini with a text editor and search for the key "AC_Adapter"
  6. Change parameter BatteryCheck from 1 to 0 or just leave it empty (this disables battery check during BIOS update preparation!), save the file
  7. Run InsydeFlash.exe in the same directory
  8. That's it, bios update should start now

Some additional notes:

  • Extracting the ZHK116.EXE manually via 7zip did not work because BIOS flash file isflash.bin (ROM file) not packed, but concatenated to the end of ZHK116.EXE file
  • Opening the ZHK116.EXE with 7zip and modifying the plattform.ini file out of 7zip did not work either, you cannot save the file
  • Updating BIOS via a bootable USB device having a FreeDOS on it did not work getting the same "battery" error (seems that the check is also done in DOS)