Linux – How to mount Safeboot encrypted Windows partiton in Ubuntu


how do I mount a SafeBoot encrypted Windows partition on Ubuntu (10.04)?

I have tried all these
mount -t ntfs /dev/sda1 /mnt/windows
tried changing fstab
tried changing grub.cfg

I also installed ntfs config tool but it doesn't detect the windows partition

but sudo fdisk -l show me the windows partition on /dev/sda1

Best Answer

You can't.

It's encrpyted. You didn't encrypt it so that your adversary could mount it in Ubuntu. On the contrary, you encrypted it so that none can mount it.

It may be telling you that /dev/sda1 is ntfs, maybe that's what's still written to the MBR but your encryption software doesn't care about the MBR table. If you could boot from another HD with Windows installed, it wouldn't mount this partition either.

What is written there is not a valid ntfs filesystem. It's something that only SafeBoot can understand after you give it your password.

Whether SafeBoot provides linux drivers that can read data from /dev/sda1 and make it available as a transparent ntfs filesystem, I don't know. I googled a bit and didn't find it.

PS: If SafeBoot indeed doesn't provide support to mount it under Ubuntu, which I believe is the case, perhaps you could try VirtualMachine solutions.

Related Question