How to fix UDI-31623 error in Oracle

databaseoracle-database

Yesterday I've tried to import another dump as a new Oracle schema and failed to to limited space. So the impdp (Data Pump Import) exited with an error. I've successfully deleted outdated schemas using the sysadmin account and then tried to start the import again. Now it always throws the following error code and I've not yet found a solution; text is in German which is what the system is set to output:

oracle@team1:~/admin/QS1/dpdump$ !impdp
impdp PARFILE=../scripts/ecg/userid.conf DUMPFILE=expdp_epl_prod__30-08-2010.dmp SCHEMAS=EPPROD REMAP_SCHEMA=EPPROD:LIVE_SQL_FINAL REMAP_TABLESPACE=EPL:USERS

Import: Release 11.1.0.7.0 - 64bit Production on Mittwoch, 01 September, 2010 9:44:44

Copyright (c) 2003, 2007, Oracle.  All rights reserved.

Angemeldet bei: Oracle Database 11g Release 11.1.0.7.0 - 64bit Production

UDI-31623: Vorgang hat ORACLE-Fehler generiert 31623
ORA-31623: Ein Job ist dieser Session nicht ├╝ber das angegebene Handle zugeordnet
ORA-06512: in "SYS.DBMS_DATAPUMP", Zeile 2862
ORA-06512: in "SYS.DBMS_DATAPUMP", Zeile 4052
ORA-06512: in Zeile 1

Translated error output is:

UDI-31623: ORACLE error process has generated 31623
ORA-31623: A job is not assigned to this session via the specified handle
ORA-06512: in "SYS.DBMS_DATAPUMP", line 2862
ORA-06512: in "SYS.DBMS_DATAPUMP", line 4052
ORA-06512: in line 1

Any ideas what might be wrong and how I can fix this?

Best Answer

Have you assigned the correct rights and roles ? Ensure you have assigned create session, create table, create procedure, imp_full_database to the user importing the dump file.

Also, assign read and write rights to the datapump directory.

grant read, write on directory <directory_name> to <user-name>
Related Question