How to configure VLC to play 4K content properly


Currently my main media player on Windows (10 Pro x64) is VLC but I noticed that when I want to play UHD content (2K, 4K videos) its freezes.

My PC's configuration: Intel i7 3770, 16GB RAM, 512GB SSD, nVidia GTX 970 4GB.

The sound is OK but the picture is freezing (2-3 frames per minutes).

I've tried to set the codecs or enabled/disabled the GPU acceleration without success.

What should I set to play this kind of content flowless?

P.S.: Media Player Classic plays the same file so smooth but I want to keep VLC as main player.

Best Answer

I have succeeded in reproducing the problem using VLC version 2.2.4.

The problem of freezing exists only if "Hardware-accelerated decoding" is set to something else than "Disable".

Apparently VLC now supports GPU decoding, but I believe it is done in a very inefficient manner.
The article How to enable gpu accelerated decoding in VLC says this :

the data is decoded in the GPU at the decoding stage and then transferred back to the player so that the other stages, filtering and streaming for instance, can be processed.

I have managed better frame-rate when setting "Hardware-accelerated decoding" to "Disable". This puts the entire burden on the CPU and so requires a strong CPU.

User Journeyman Geek recommends increasing the thread number under Tools / Preferences / Video Codecs" / FFMPEG / Threads, but it worked for me with the default value of 0 which means "Auto". You might experiment further with other values for Threads. I just remark that the FFMPEG library is not used for all video formats.

VLC apparently does not support at the moment (2016) the x265 codec, since x265 videos did not play when downloaded from However, everything worked flawlessly with Media Player Classic.

Edit (2018) : VLC now works successfully with these files.

Related Question