Google-chrome – Why is not working with chrome or firefox


I have a 14.43 GB file in my cloud that i am trying to download off Which consists mostly of some recent manual backups of the desktop files in my mums old laptop, which now has been wiped clean.

I first started downloading my file using google chrome with the extension, it would get up to 75% and crash. Oblivious to this crash, i tried again 3 more times and it would end with the same result (cant remember the details of the crash message but it wasn't much help).

After doing a little bit of research i found that it was a "bug" in the javascript engine of google chrome, where it would crash when the memory gets clunked up without releasing those blocks. After trying once again with releasing chromes cookies and deleting my temp memory, i ended up having the same results.

This was getting really annoying and just time consuming since my mum was left without a computer for her work and also that the download would start back from 0% each and every time it crashed (5-6hrs on my slow internet connection).

I used mozilla firefox because it was recommended and it finally reached 100% on the file transfer queue, after that i waited all night for the mozilla firefox to add it to its own download queue but it never happened. after doing a little bit more research, i found that some other users that were trying to download large files from their own mega cloud were having the same issue on firefox.

Any help on this subject would be greatly appreciated.

edit: I was using their official extensions in both browsers.

Best Answer

Temporary and a time consuming solution to this, created partitions of the files in my main folder that i was trying to download inside the mega application. partitions of roughly about 1gb each made the process go a lot smoother.

other users have suggested using JDownloader, not a big fan of it myself but feel free to try it with mega.

Related Question