Formatting a bootable USB that thinks it’s a CD-ROM


After upgrading to Windows 10, I remember that I had an old bootable recovery usb drive from the manufacturer that I no longer needed. I want to format it but it's showing up as a CD-ROM and format options are not available.

I also tried formatting it in a live linux mint environment, but linux cannot even mount the cd-rom.

How can I format this recovery usb that is showing up as a cd-rom?

Best Answer

The fact that this device shows up as a CD-ROM may be an intentional design by the manufacturer, especially if it contains recovery utilities.

The USB spec doesn't really care what the devices physically are or look like other than the socket/plug, so it's possible for a manufacturer to make a device that reports it is a CD-ROM to the OS, without it physically being a CD-ROM. This path is chosen by the manufacturer because just about all OS's by default support CD-ROMs.

It's also possible for a USB device to actually be several logical devices, so you might also more typically run into a device that, when plugged in, gives you a "CD-ROM" as well as other devices.

Some external hard drives have utilities that appear on a separate "CD-ROM" device, in addition to the main storage device that is actually the hard drive itself. Some Western Digital external hard drives and the Sandisk "U3" disks worked like this. More than one type of USB cellular modem also does this, to try to allow drivers to be automatically installed by plugging the device in. My phone has an option to go in an "Installer" mode, which looks like a CD-ROM to the OS, which allows installation of a driver.

So, the chipset/firmware within the device itself is responsible for this. The manufacturer may provide a utility to change or remove the configuration (Western Digital and Sandisk does for their external hard/flash drives). It's unlikely given that your USB device was not intended to be modified by the end user, but you may try to find out the real manufacturer of the USB device and see if there is a utility that could reconfigure the firmware on it.

Related Question