Connecting to own IP not working


I am able to connect to my machine using my external IP address from remote computers with no issue, but from my own computer I am unable to connect using my external IP.

How can I configure my router so that I can use my external IP to connect to my own network?

I read that some routers tend to drop packets where the source and destination IP are the same, apparently this is one, but can I change that somehow in the configuration or would I simply need a better router? The one I have (brand below) comes with FairPoint's DSL service.

For context

My network configuration is as follows:

- Westell VersaLink 7500 DSL modem/router (IP: 70.x.y.z)
-- Server (IP: 192.168.1.m)
---- Virtual Machine: (IP: 10.a.b.c)
-- Laptop (IP: 192.168.1.n)

So, I have a website running on port 8080 in the VM, I have port forwarding enabled on the VM software which forwards 8080 on the host ("Server" / 192.168.1.m) to 8080 on the VM (10.a.b.c). I am able to connect from (Server or Laptop) to the VM using (Server's IP or the VM's IP), and users outside my network are able to connect to the VM using my external IP (70.x.y.z) as I have port 8080 forwarded to Server's IP (192.168.1.m) in my router's settings.

Best Answer

Most likely, your router just doesn't support hairpin NAT. You can see if there's a firmware upgrade for your router.

Related Question